Opened 2 years ago

Closed 17 months ago

#1055 closed Bug Report (fixed)

ingenish set not working

Reported by: gromp Owned by: dave
Priority: major Component: Ingen
Keywords: Cc:

Description

doing the following as is documented in "ingenish help" does not work:

    ingenish put /tone 'a ingen:Block ; lv2:prototype <http://drobilla.net/plugins/mda/Shepard>'
    ingenish set /tone/output 'ingen:value 0.7'

/tone is created, but ingen hangs and I receive the following error in the ingen stdout:

Set message missing property

the terminal where I input the command doesn't output anything until after I Ctrl+C, where it simply outputs "error:" .

Attachments (1)

ingen-set.jpg (22.8 KB) - added by gromp 21 months ago.
result of set command

Download all attachments as: .zip

Change History (11)

comment:1 Changed 2 years ago by gromp

it seems as though this command is expecting another argument; if I input

    ingenish set /tone/output 'ingen:value 0.7' ''

then there no errors, but nothing happens.

comment:2 Changed 22 months ago by dave

  • Resolution set to fixed
  • Status changed from new to closed

I've changed this to use the simpler syntax set KEY VALUE, e.g.

ingenish set /tone/output ingen:value 0.7

Since you can only set one property with set anyway. The extra argument problem got fixed along the way.

comment:3 Changed 21 months ago by gromp

  • Resolution fixed deleted
  • Status changed from closed to reopened

it seems that set is almost working but I am unable to modify the "value" field. executing

ingenish set /tone/output ingen:value 0.7

results in a new field called "ingen:value" being created with that value set to 0.7 instead of the existing "value" field being updated. Subsequent calls to set ingen:value change ingen:value as well.

I also tried

ingenish set /tone/output value 0.7

but a new field called "ingen:/value" then gets created and modified.

comment:4 Changed 21 months ago by dave

Please explain precisely what you mean by 'unable to modify the "value" field'. You get two ingen:value properties as a result of a set?

Changed 21 months ago by gromp

result of set command

comment:5 Changed 21 months ago by gromp

i attached what happens when I run the two aforementioned 'ingenish set /graph/tone/output [value] 0.7' commands.

Last edited 21 months ago by gromp (previous) (diff)

comment:6 Changed 21 months ago by dave

Oh. The set command takes a URI. It does not support prefixed CURIES.

Since these are ambiguous, some syntax would be required to allow both. I suppose if Turtle is currently in the interface anyway, it can just be that (quoted like <http://example.org>)...

comment:7 Changed 21 months ago by gromp

I don't understand what you mean, what is the "correct" way to set the value then in the above example?

comment:8 Changed 21 months ago by dave

ingenish set /tone/output http://drobilla.net/ns/ingen#value 0.7

comment:9 Changed 21 months ago by gromp

oh, I see, that works. It'd be nice if CURIEs were supported too though.

comment:10 Changed 17 months ago by dave

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.