Opened 13 years ago

Closed 13 years ago

#187 closed Bug Report (fixed)

patchage won't build with gcc 4.3

Reported by: sakari Owned by:
Priority: major Component: Patchage
Keywords: Cc:

Description

I tried to compile patchage but making failed with:

In file included from Driver.hpp:24,
                 from JackDriver.hpp:27,
                 from Patchage.cpp:33:
PatchageEvent.hpp: In constructor ‘PatchageEvent::PatchageEvent(PatchageEvent::Type, const char*)’:
PatchageEvent.hpp:51: error: ‘strdup’ was not declared in this scope
PatchageEvent.hpp: In constructor ‘PatchageEvent::PortRef::PortRef()’:
PatchageEvent.hpp:75: error: ‘memset’ was not declared in this scope
Patchage.cpp: In constructor ‘Patchage::Patchage(int, char**)’:
Patchage.cpp:136: error: ‘strcmp’ was not declared in this scope
make[1]: *** [Patchage.o] Error 1
make[1]: Leaving directory `/var/abs/local/ownbuilds/patchage/patchage-0.4.1/src'
make: *** [all-recursive] Error 1

Adding

#include <cstring>

to src/PatchageEvent.hpp solved that one for me. I'm running patchage on archlinux with gcc 4.3.1 installed. I also configured patchage for jack only (alsa and lash disabled) if that matters?

Change History (1)

comment:1 Changed 13 years ago by David Robillard

Resolution: fixed
Status: newclosed

Already fixed in SVN.

Note: See TracTickets for help on using tickets.