Opened 10 years ago

Closed 10 years ago

#629 closed Bug Report (duplicate)

...giomm/dbusmessage.h:706:1: error: expected declaration before ‘}’ token

Reported by: Thorsten Wilms Owned by: David Robillard
Priority: major Component: Build System
Keywords: giomm Cc: t_w_@…

Description

Unless configured with --no-lash, Build fails with:

[214/291] cxx: patchage/src/DBus.cpp -> build/patchage/src/DBus.cpp.1.o
In file included from /usr/include/giomm-2.4/giomm/dbusconnection.h:34,
                 from /usr/include/giomm-2.4/giomm.h:32,
                 from /usr/include/gtkmm-2.4/gtkmm.h:88,
                 from /usr/include/libgnomecanvasmm-2.6/libgnomecanvasmm.h:29,
                 from ../patchage/src/Patchage.hpp:26,
                 from ../patchage/src/DBus.cpp:24:
/usr/include/giomm-2.4/giomm/dbusmessage.h:51:3: error: expected identifier before numeric constant
/usr/include/giomm-2.4/giomm/dbusmessage.h:51:3: error: expected ‘}’ before numeric constant
/usr/include/giomm-2.4/giomm/dbusmessage.h:51:3: error: expected unqualified-id before numeric constant
/usr/include/giomm-2.4/giomm/dbusmessage.h:186:11: error: ‘DBusMessage_Class’ does not name a type
In file included from /usr/include/giomm-2.4/giomm/dbusconnection.h:34,
                 from /usr/include/giomm-2.4/giomm.h:32,
                 from /usr/include/gtkmm-2.4/gtkmm.h:88,
                 from /usr/include/libgnomecanvasmm-2.6/libgnomecanvasmm.h:29,
                 from ../patchage/src/Patchage.hpp:26,
                 from ../patchage/src/DBus.cpp:24:
/usr/include/giomm-2.4/giomm/dbusmessage.h:352:3: error: ‘DBusMessageType’ does not name a type
/usr/include/giomm-2.4/giomm/dbusmessage.h:359:25: error: ‘DBusMessageType’ has not been declared
/usr/include/giomm-2.4/giomm/dbusmessage.h:706:1: error: expected declaration before ‘}’ token
Waf: Leaving directory `/usr/src/drobilla-lad_fail/build'
Build failed
 -> task failed (exit status 1): 
	{task 25396816: cxx DBus.cpp -> DBus.cpp.1.o}
['/usr/bin/g++', '-O0', '-g', '-fPIC', '-DPIC', '-fshow-column', '-I/usr/src/drobilla-lad_fail/build', '-iquote /usr/src/drobilla-lad_fail/lv2core', '-iquote /usr/src/drobilla-lad_fail/flowcanvas', '-iquote /usr/src/drobilla-lad_fail/raul', '-iquote /usr/src/drobilla-lad_fail/slv2', '-iquote /usr/src/drobilla-lad_fail/redlandmm', '-iquote /usr/src/drobilla-lad_fail/ingen', '-iquote /usr/src/drobilla-lad_fail/serd', '-iquote /usr/src/drobilla-lad_fail/machina', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-I/usr/src/drobilla-lad_fail/build/patchage', '-I/usr/src/drobilla-lad_fail/patchage', '-I/usr/src/drobilla-lad_fail/build/patchage/src', '-I/usr/src/drobilla-lad_fail/patchage/src', '-I/usr/src/drobilla-lad_fail/build/flowcanvas', '-I/usr/src/drobilla-lad_fail/flowcanvas', '-I/usr/src/drobilla-lad_fail/build/raul', '-I/usr/src/drobilla-lad_fail/raul', '-I/usr/include/glib-2.0', '-I/usr/lib/glib-2.0/include', '-I/usr/include/graphviz', '-I/usr/include/gtkmm-2.4', '-I/usr/lib/gtkmm-2.4/include', '-I/usr/include/giomm-2.4', '-I/usr/include/pangomm-1.4', '-I/usr/lib/pangomm-1.4/include', '-I/usr/include/gtk-2.0', '-I/usr/include/gtk-unix-print-2.0', '-I/usr/include/atkmm-1.6', '-I/usr/include/gdkmm-2.4', '-I/usr/lib/gdkmm-2.4/include', '-I/usr/include/glibmm-2.4', '-I/usr/lib/glibmm-2.4/include', '-I/usr/include/sigc++-2.0', '-I/usr/lib/sigc++-2.0/include', '-I/usr/include/cairomm-1.0', '-I/usr/lib/cairomm-1.0/include', '-I/usr/include/pango-1.0', '-I/usr/include/cairo', '-I/usr/include/pixman-1', '-I/usr/include/freetype2', '-I/usr/include/libpng12', '-I/usr/lib/gtk-2.0/include', '-I/usr/include/atk-1.0', '-I/usr/include/gdk-pixbuf-2.0', '-I/usr/include/gio-unix-2.0', '-I/usr/include/dbus-1.0', '-I/usr/lib/dbus-1.0/include', '-I/usr/include/libglademm-2.4', '-I/usr/lib/libglademm-2.4/include', '-I/usr/include/libglade-2.0', '-I/usr/include/libxml2', '-I/usr/include/libgnomecanvasmm-2.6', '-I/usr/lib/libgnomecanvasmm-2.6/include', '-I/usr/include/libgnomecanvas-2.0', '-I/usr/include/gail-1.0', '-I/usr/include/libart-2.0', '-I/usr/include/alsa', '-I/usr/src/drobilla-lad_fail/build', '-I/usr/src/drobilla-lad_fail/build/../lv2/core.lv2', '-DSERD_VERSION="0.1.0"', '-DHAVE_SERD=1', '-DHAVE_LV2CORE=1', '-DHAVE_LV2=1', '-DHAVE_REDLAND=1', '-DHAVE_JACK=1', '-DSLV2_VERSION="0.6.7"', '-DSLV2_DEFAULT_LV2_PATH="~/.lv2:/usr/local/lib/lv2:/usr/local/lib/lv2"', '-DHAVE_LV2_EVENT=1', '-DHAVE_LV2_URI_MAP=1', '-DHAVE_SLV2=1', '-DHAVE_GLIB=1', '-DHAVE_GTHREAD=1', '-DRAUL_LOG_COLOUR=1', '-DHAVE_BOOST_SHARED_PTR_HPP=1', '-DHAVE_BOOST_WEAK_PTR_HPP=1', '-DHAVE_BOOST_UTILITY_HPP=1', '-DHAVE_RAUL=1', '-DHAVE_AGRAPH=1', '-DHAVE_GLIBMM=1', '-DHAVE_GNOMECANVASMM=1', '-DHAVE_FLOWCANVAS=1', '-DHAVE_DBUS=1', '-DHAVE_DBUS_GLIB=1', '-DHAVE_GTKMM=1', '-DHAVE_GLADEMM=1', '-DHAVE_DLADDR=1', '-DPATCHAGE_LIBJACK=1', '-DHAVE_JACK_MIDI=1', '-DHAVE_ALSA=1', '-DHAVE_LASH=1', '-DPATCHAGE_BINLOC=1', '-DPATCHAGE_DATA_DIR="/usr/local/share/patchage"', '-DHAVE_PATCHAGE=1', '-DHAVE_RAPTOR=1', '-DHAVE_REDLANDMM=1', '-DHAVE_NEW_GTKMM=1', '-DHAVE_XML2=1', '-DHAVE_SOUP=1', '-DHAVE_LADSPA_H=1', '-DHAVE_LIBLO=1', '-DHAVE_POSIX_MEMALIGN=1', '-DHAVE_LV2_LV2PLUG_IN_NS_LV2CORE_LV2_H=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_ATOM_ATOM_H=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_CONTEXTS_CONTEXTS_H=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_EVENT_EVENT_HELPERS_H=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_RESIZE_PORT_RESIZE_PORT_H=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_URI_UNMAP_URI_UNMAP_H=1', '-DINGEN_VERSION="0.5.1"', '-DINGEN_BUILD_GUI=1', '-DINGEN_DATA_DIR="/usr/local/share/ingen"', '-DINGEN_MODULE_DIR="/usr/local/lib"', '-DHAVE_INGEN=1', '-DHAVE_RASQAL=1', '-DMACHINA_PPQN=19200', '-DMACHINA_VERSION="0.5.0"', '-DMACHINA_BUILD_GUI=1', '-DMACHINA_DATA_DIR="/usr/local/share/machina"', '-DHAVE_MACHINA=1', '-DHAVE_LV2_LV2PLUG_IN_NS_EXT_ATOM_ATOM_HELPERS_H=1', '-DHAVE_USB=1', '-DHAVE_SIGC=1', '-DDIRG_VERSION="0.6.7"', '-DDIRG_WITH_HTTP=1', '-DDIRG_WITH_LAUNCHPAD=1', '-DHAVE_PLUGINS_DIRG_LV2=1', '-DHAVE_PLUGINS_LOLEP_LV2=1', '../patchage/src/DBus.cpp', '-c', '-o', 'patchage/src/DBus.cpp.1.o']

Change History (2)

comment:1 Changed 10 years ago by Thorsten Wilms

Related, perhaps same: #620

comment:2 Changed 10 years ago by David Robillard

Resolution: duplicate
Status: newclosed

Duplicate of #620

Note: See TracTickets for help on using tickets.