Opened 10 years ago

Closed 10 years ago

#650 closed Bug Report (fixed)

FTBFS: slv2 (lv2_inspect) requires glib >= 2.22

Reported by: Gabriel M. Beddingfield Owned by: David Robillard
Priority: minor Component: Build System
Keywords: slv2, ingen, glib Cc: gabrbedd@…

Description

Building Ingen (trunk r3036) fails to build with the following error:

[262/285] cprogram: build/slv2/utils/lv2_inspect.c.3.o -> build/slv2/utils/lv2_inspect                             
slv2/libslv2.so: undefined reference to `g_ptr_array_new_with_free_func'                                           
slv2/libslv2.so: undefined reference to `g_ptr_array_unref'                                                        
collect2: ld returned 1 exit status                                                                                

These symbols were introduced with glib 2.22. I was building on Debian Lenny (old stable), which is using glib 2.19.6.

Change History (1)

comment:1 Changed 10 years ago by David Robillard

Resolution: fixed
Status: newclosed

Fixed in r3054.

Note: See TracTickets for help on using tickets.