Opened 3 years ago

Closed 4 months ago

#823 closed Bug Report (fixed)

Sometimes virtual devices don't show up.

Reported by: keinstein Owned by: dave
Priority: major Component: Patchage
Keywords: Cc:

Description

Hi,

using Mutabor (http://www.math.tu-dresden.de/~mutabor) I not all Midi ports of the software are shown by patchage. The software connects to other MIDI devices using RtMidi?. When it opens a MIDI device it assigns the name of the port on the other end of the link to the corresponding port e.g.: the port linked to “Midi through” is named “Midi through:0”. Thus, it is easy to establish the correct matchings between ports as named in Mutabor and ports as seen by ALSA (e.g. aconnect or patchage). Unfortunately patchage loses some of the ports. When I connect my Keyboard to the software, patchage only shows the Mutabor output port, which is linked to the input of my keyboard.

The other port is not shown in patchage. When I link mutabor to another device the input port appears sometimes but when I connect the other end of Mutabor to the corresponding device it disappears again.

At the end I find error messeges like

Unable to find port `alsa:132:0:in' to disconnect
Unable to find port `alsa:132:0:in' to destroy
Unable to find port `alsa:132:0:out' to destroy
[ALSA] Attempt to subscribe ports that are already subscribed.
[ALSA] Subscription failed: Das Gerät oder die Ressource ist belegt
Unable to find port `alsa:132:0:out' to destroy
Unable to find port `alsa:132:0:out' to destroy

in the console.

Maybe it's related to some bug one of my friends had: On his computer patchage sometimes attatched some links to the wrong device I don't remember wether outgoning connections were linked to the input port of the software or vice versa (while I'm using ALSA, he used Jack connections).

Change History (2)

comment:1 Changed 11 months ago by dave

I can't figure out how to make mutabor do anything to confirm this problem. Can you try again with the current version and confirm whether or not these issues still exist?

comment:2 Changed 4 months ago by dave

  • Resolution set to fixed
  • Status changed from new to closed

I can't reproduce this, haven't heard about it from anyone else since, and it's over two years old. Assuming fixed.

Note: See TracTickets for help on using tickets.