wiki:IngenBasics

Where's File->Open?!

There isn't one, deliberately. Ingen (like the Unix filesystem) always has a "root patch", with the path "/". This is the patch you see when you first start the GUI. You can't "open" in this window because the operation is ambigious - if there were objects present would the loaded patch it replace them? Load as a child? Import to the root patch? To avoid this ambiguity and confusion there is only an "Import" option, which does what you would expect.

Loading Child Patches

You can import into the root patch, but that's not the only way to load a patch. Ingen is a recursive environment - if you want to load e.g. a synth patch, you can load it as a child of the root patch. Think of the root patch as representing the entire Ingen system itself, which can contain many instruments (or whatever else). Depending on how Ingen fits into the rest of your audio setup, you might think of the root patch as your "workspace" or "project". You can also just build whatever you need in the root patch, it is just a matter of style and organization.

Loading children of a patch (any patch) is done via the context menu. This is a very important concept when using Ingen: Right Click The Canvas!

It is not even possible to load subpatches or plugins via the menus or any way other than via the canvas context menu, because you need to specify where (visually) you want the new object to be placed. You do this by bringing up the menu, and the new object will be added where you (right) clicked. The goal is for using Ingen to be like using a drawing program. GIMP doesn't have a Draw->Circle menu item because that would be silly - Ingen doesn't have an Add->Plugin menu item for the exact same reason.

Connecting Ports

Important: Signal flow in Ingen goes from left to right. Thus you can distinguish input ports from output ports because inputs are aligned to the left of the node, and output ports are aligned to the right. If you prefer a vertical signal flow ala pure data or Max, View->Port Labels will toggle between the horizontal labelled style and the vertial non-labelled style (the vertical is significantly faster at loading if you are working with extremely large patches). There are a few ways of connecting ports:

  • The click-click method: click one of the ports (it should be highlighted red), then click the port you want it connected to. Assuming the ports are capable of being connected to each other, a connection should be made.
  • The drag method: Drag from the source (output) port to the destination (input) port.
  • Multi-connect: Select several ports in the usual way (hold shift and click them all). Press enter and all the ports will be connected in the "best" way. "Best" is naturally a fuzzy idea... if this doesn't do what you expect in some case, file a ticket.

Ingen will automatically mix when a port has several connections.

Disconnecting Ports

Disconnecting ports is done in the exact same way as you would connect them (any method is fine). You can also disconnect everything from a node or port from that object's context menu.

Last modified 7 years ago Last modified on 09/07/10 11:40:28