Changes between Version 1 and Version 2 of IngenBasics


Ignore:
Timestamp:
Nov 25, 2008, 11:39:30 AM (12 years ago)
Author:
David Robillard
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • IngenBasics

    v1 v2  
    11== Where's File->Open?! ==
     2
    23
    34There isn't one, deliberately.  Ingen (like the Unix filesystem) always has a "root patch", with the path "/".  This is the patch you see when you first start the GUI.  You can't "open" in this window because the operation is ambigious - if there were objects present would the loaded patch it replace them?  Load as a child?  Import to the root patch?  To avoid this ambiguity and confusion there is only an "Import" option, which does what you would expect.
     
    56
    67
    7 == Loading Patches ==
     8== Loading Child Patches ==
    89
    9 You can import into the root patch, but there's a very good chance that's not what you ''should'' do.  Ingen is a recursive environment - if you want to load e.g. a synth patch, you should load it as a ''child'' of the root patch.  Think of the root patch as representing the entire Ingen system itself, which can contain many instruments (or whatever else).  Depending on how Ingen fits into the rest of your audio setup, you might think of the root patch as your "workspace" or "project".
     10You can import into the root patch, but that's not the only way to load a patch.  Ingen is a recursive environment - if you want to load e.g. a synth patch, you can load it as a ''child'' of the root patch.  Think of the root patch as representing the entire Ingen system itself, which can contain many instruments (or whatever else).  Depending on how Ingen fits into the rest of your audio setup, you might think of the root patch as your "workspace" or "project".  You can also just build whatever you need in the root patch, it is just a matter of style and organization.
    1011
    11 Loading children of a patch (any patch) is done via a context menu.  This is a very important concept when using Ingen:  '''Right Click The Canvas'''!
     12Loading children of a patch (any patch) is done via the context menu.  This is a very important concept when using Ingen: ''' Right Click The Canvas! '''
    1213
    13 It is not even possible to load subpatches or plugins via the menus or any way other than via the canvas context menu, because you need to specify where you want the new object to be.  You do this by bringing up the menu, and the new object will be added where you (right) clicked.  The goal is for using Ingen to be like using a drawing program.  GIMP doesn't have a Draw->Circle menu item because that would be silly - Ingen doesn't have an Add->Plugin menu item for the exact same reason.
    14 
    15 
    16 
    17 == Adding Nodes (plugins) and Ports ==
    18 
    19 You guessed it - right-click the canvas.  If you feel more documentation is required here please tell Dave, because the GUI needs fixing - not the documentation.
     14It is not even possible to load subpatches or plugins via the menus or any way other than via the canvas context menu, because you need to specify where (visually) you want the new object to be placed.  You do this by bringing up the menu, and the new object will be added where you (right) clicked.  The goal is for using Ingen to be like using a drawing program.  GIMP doesn't have a Draw->Circle menu item because that would be silly - Ingen doesn't have an Add->Plugin menu item for the exact same reason.
    2015
    2116
     
    2318== Connecting Ports ==
    2419
    25 '''Important: ''' Signal flow on Nodes in Ingen flows from left to right.  Thus you can distinguish input ports from output ports because inputs are aligned to the left of the node, and output ports are aligned to the right.
     20'''Important: ''' Signal flow in Ingen goes from left to right.  Thus you can distinguish input ports from output ports because inputs are aligned to the left of the node, and output ports are aligned to the right.  If you prefer a vertical signal flow ala pure data or Max, View->Port Labels will toggle between the horizontal labelled style and the vertial non-labelled style (the vertical is significantly faster at loading if you are working with extremely large patches).
    2621 
    27 There are two ways of connecting ports:
     22There are a few ways of connecting ports:
    2823
    2924 * The click-click method: click one of the ports (it should be highlighted red), then click the port you want it connected to.  Assuming the ports are capable of being connected to each other, a connection should be made.
     
    3126 * The drag method:  Drag from the source (output) port to the destination (input) port.
    3227
     28 * Multi-connect: Select several ports in the usual way (hold shift and click them all).  Press enter and all the ports will be connected in the "best" way.  "Best" is naturally a fuzzy idea... if this doesn't do what you expect in some case, file a ticket.
     29
    3330
    3431
    3532== Disconnecting Ports ==
    3633
    37 Disconnecting two ports is done in the exact same way as you would connect them.  Either method is fine.
     34Disconnecting ports is done in the exact same way as you would connect them (any method is fine).  You can also disconnect everything from a node or port from that object's context menu.