Opened 6 years ago

Closed 6 years ago

#1086 closed Bug Report (fixed)

fix gtk2, x11 in qt5 [patch]

Reported by: Rui Nuno Capela Owned by: David Robillard
Priority: major Component: Suil
Keywords: Cc:

Description

Fix basic support for Qt5 GUI hosts on two new wrappers: libsuil_gtk2_in_qt5 and libsuil_x11_in_qt5. (EXPERIMENTAL)

Attachments (3)

suil-0.8.3svn5726-qt5-3.patch (3.3 KB) - added by Rui Nuno Capela 6 years ago.
suil-0.8.3svn5726-qt5-4.patch (3.3 KB) - added by Rui Nuno Capela 6 years ago.
jalv-1.4.7svn5726-qt5-4.patch (1003 bytes) - added by Rui Nuno Capela 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Rui Nuno Capela

Changed 6 years ago by Rui Nuno Capela

Changed 6 years ago by Rui Nuno Capela

comment:1 Changed 6 years ago by Rui Nuno Capela

new patches attached:

  1. suil-0.8.3svn5726-qt5-4.patch​ ­-- replaces previous one (suil-0.8.3svn5726-qt5-3.patch​);
  2. jalv-1.4.7svn5726-qt5-4.patch -- fixes jalv.qt5 build via moc-qt5.

comment:2 Changed 6 years ago by David Robillard

I do not have a moc-qt5 (Debian).

comment:3 in reply to:  2 Changed 6 years ago by Rui Nuno Capela

Replying to dave:

I do not have a moc-qt5 (Debian).

but i do (opensuse13.2) :) on systems with both qt4 and qt5 installed, you end up with either moc-qt4 or moc-qt5, or even both. i believe debian also provides the qtchooser elper to select the default environment, either qt4 or qt5 (also via QT_SELECT env.variable).

anyway, i had to add the option to lookup for "moc-qt5" because jalv.qt5 was FTBFS due to (my) current "moc" defaults to the qt4's version.

byee

Version 0, edited 6 years ago by Rui Nuno Capela (next)

comment:4 Changed 6 years ago by David Robillard

Resolution: fixed
Status: newclosed

Applied in r5729 and r5730, except the destruction kludges which just caused crashes for me.

Note: See TracTickets for help on using tickets.