Opened 6 years ago

Last modified 5 years ago

#1102 new Bug Report

Ingen fails to open in Carla or MusE as LV2 plugin.

Reported by: therealkitman Owned by: David Robillard
Priority: blocker Component: Ingen
Keywords: Muse Carla Cc:



after downloading rev 5787 of Ingen today to fix an issue with the x42-scope not working, my saved Ingen graphs no longer load in either Carla or MusE whereas they did load before.

I get the messages -

MusE error - lilv_lib_open(): error: Failed to open library /home/chris/.lv2/ingen.lv2/ (/home/chris/.lv2/ingen.lv2/ undefined symbol: _ZN5Ingen10AtomReader10is_messageERNS_4URIsEPK8LV2_Atom) createSynthInstance: synthi class:libingen_lv2 label:ingentest2.ttl LV2 can not be created

Carla error - /home/chris/.lv2/ingen.lv2/ undefined symbol: _ZN5Ingen10AtomReader10is_messageERNS_4URIsEPK8LV2_Atom

Regards, Chris.

Attachments (2)

config.log (99.8 KB) - added by therealkitman 6 years ago. (2.8 KB) - added by therealkitman 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by falkTX

I think you just need to do a waf clean and build again. I have '-Wl,--no-undefined' in my LDFLAGS so undefinied symbols never happen.

I do get a crash when loading latest ingen though, but that's a separate issue.

comment:2 Changed 6 years ago by therealkitman

I just did a 'waf uninstall' followed by a 'waf clean' then rebuilt.

I get the same error message in Carla though the standalone ingen works fine.

comment:3 Changed 6 years ago by David Robillard

Yes, pretty sure this is a stale build of some variety. Works fine for me (and I also use -Wl,--no-undefined).

Is ~/.lv2/ingen.lv2 actually the version you just built, or an old one? The use of unconventional paths suggests that you may have different/incompatible builds of Ingen installed in several different locations...

Please attach build/config.log

Changed 6 years ago by therealkitman

Attachment: config.log added

comment:4 Changed 6 years ago by therealkitman


I have cleaned my installations up a bit and did a standard install. Config.log attached. Ingen still runs fine as a standalone.

However, in Carla and MusE i now get segmentation faults when I try and load a newly created ingen graph.

Block: 128 frames, Sequence: 8192 bytes LV2 parse resource file:///home/chris/.lv2/dummy.ingen/dummy.ttl from /home/chris/.lv2/dummy.ingen/dummy.ttl sh: line 1: 4904 Segmentation fault ./carla

Block: 128 frames, Sequence: 128 bytes LV2 parse resource file:///home/chris/.lv2//dummy.ingen/dummy.ttl from /home/chris/.lv2dummy.ingen/dummy.ttl Loading file:///home/chris/.lv2//dummy.ingen/dummy.ttl from /home/chris/.lv2dummy.ingen/dummy.ttl Segmentation fault

I'll admit I'm not too clever with building but I can't see where I've gone wrong.

comment:5 Changed 6 years ago by David Robillard

Will need a backtrace from gdb to have any idea what's going on there.

Changed 6 years ago by therealkitman

Attachment: added

comment:6 Changed 6 years ago by therealkitman

Hi, I have installed gdb and got this result in the attached zip file. I'm not too sure if I ran gdb right since I have not used it before.


comment:7 Changed 5 years ago by David Robillard

This is just a backtrace of running ingen with no arguments, which simply prints the help message and exits.

I need a backtrace of the actual situation that shows the bug, i.e. running ingen in carla.

Note: See TracTickets for help on using tickets.