Opened 13 years ago

Closed 13 years ago

#194 closed Bug Report (fixed)

crash when changing polyphony

Reported by: kfoltman Owned by:
Priority: major Component: Ingen
Keywords: Cc:

Description

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb54e8b90 (LWP 20919)]
__dynamic_cast (src_ptr=0xb1ea1ea8, src_type=0xb70ca1c0, dst_type=0xb70ca198, src2dst=0) at ../../.././libstdc++-v3/libsupc++/dyncast.cc:48
48	  const __class_type_info *whole_type = prefix->whole_type;
(gdb) bt
#0  __dynamic_cast (src_ptr=0xb1ea1ea8, src_type=0xb70ca1c0, dst_type=0xb70ca198, src2dst=0) at ../../.././libstdc++-v3/libsupc++/dyncast.cc:48
#1  0xb704ed35 in Ingen::AudioBuffer::join (this=0xb1436fc0, buf=0xb1ea1ea8) at AudioBuffer.cpp:241
#2  0xb7057a9b in Ingen::InputPort::apply_poly (this=0xb1ef3920, maid=@0x80e3a48, poly=2) at InputPort.cpp:87
#3  0xb70662da in Ingen::NodeBase::apply_poly (this=0xb1ebc410, maid=@0x80e3a48, poly=2) at NodeBase.cpp:126
#4  0xb70a237b in Ingen::LADSPANode::apply_poly (this=0xb1ebc410, maid=@0x80e3a48, poly=2) at LADSPANode.cpp:102
#5  0xb7076909 in Ingen::PatchImpl::apply_internal_poly (this=0x80e0968, maid=@0x80e3a48, poly=2) at PatchImpl.cpp:124
#6  0xb709fc39 in Ingen::SetPolyphonyEvent::execute (this=0x8757208, context=@0x81017e4) at events/SetPolyphonyEvent.cpp:60
#7  0xb707ec97 in Ingen::QueuedEventSource::process (this=0x80c9338, dest=@0x8063690, context=@0x81017e4) at QueuedEventSource.cpp:105
#8  0xb7053117 in Ingen::Engine::process_events (this=0x80c5710, context=@0x81017e4) at Engine.cpp:310
#9  0xb70591b9 in Ingen::JackAudioDriver::_process_cb (this=0x8101718, nframes=64) at JackAudioDriver.cpp:317
#10 0xb705a974 in Ingen::JackAudioDriver::process_cb (nframes=64, jack_driver=0x8101718) at JackAudioDriver.hpp:153
#11 0xb7e9cd34 in ?? () from /usr/lib/libjack.so.0
#12 0xb7ead903 in Jack::JackPosixThread::ThreadHandler () from /usr/lib/libjack.so.0
#13 0xb79a54fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0xb74a1e5e in clone () from /lib/tls/i686/cmov/libc.so.6

This is rev 1489, so maybe it has already been fixed.

Attachments (1)

octsqr4voice5a.ingen.ttl (23.7 KB) - added by kfoltman 13 years ago.
This file seems to crash the r1627 of ingen, due to control-audio connection stuff

Download all attachments as: .zip

Change History (5)

comment:1 Changed 13 years ago by kfoltman

Similar crash on reducing polyphony after a patch was imported from a file.

(gdb) bt #0 0xb71b09a4 in Ingen::InputPort::apply_poly (this=0xb2003e80,

maid=@0x80d5d20, poly=4) at InputPort?.cpp:87

#1 0xb71bf2ba in Ingen::NodeBase::apply_poly (this=0xb2aeacc8,

maid=@0x80d5d20, poly=4) at NodeBase?.cpp:126

#2 0xb71f760b in Ingen::LADSPANode::apply_poly (this=0xb2aeacc8,

maid=@0x80d5d20, poly=4) at LADSPANode.cpp:102

#3 0xb71cbbd9 in Ingen::PatchImpl::apply_internal_poly (this=0x8062b10,

maid=@0x80d5d20, poly=4) at PatchImpl?.cpp:124

#4 0xb71f4ec9 in Ingen::SetPolyphonyEvent::execute (this=0x87c7c20,

context=@0x80ee8ac) at events/SetPolyphonyEvent.cpp:60

#5 0xb71d3f57 in Ingen::QueuedEventSource::process (this=0x80d5c88,

dest=@0x80d1318, context=@0x80ee8ac) at QueuedEventSource?.cpp:105

#6 0xb71a82e7 in Ingen::Engine::process_events (this=0x80d59d0,

context=@0x80ee8ac) at Engine.cpp:310

#7 0xb71b20a9 in Ingen::JackAudioDriver::_process_cb (this=0x80ee7e0,

nframes=256) at JackAudioDriver?.cpp:317

#8 0xb71b3864 in Ingen::JackAudioDriver::process_cb (nframes=256,

jack_driver=0x80ee7e0) at JackAudioDriver?.hpp:153

#9 0xb7fb19e2 in jack_client_thread (arg=0x811fdc0) at client.c:1601 #10 0xb7b094fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0 #11 0xb75c0e5e in clone () from /lib/tls/i686/cmov/libc.so.6

comment:2 Changed 13 years ago by kfoltman

I mean,

(gdb) thread apply all bt

Thread 24 (Thread 0xb3effb90 (LWP 3654)):
#0  0xb7fe0410 in __kernel_vsyscall ()
#1  0xb7b0ddd2 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb77c3077 in ?? () from /usr/lib/libgthread-2.0.so.0
#3  0xb767de31 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb767df66 in g_async_queue_timed_pop () from /usr/lib/libglib-2.0.so.0
#5  0xb76cc9da in ?? () from /usr/lib/libglib-2.0.so.0
#6  0xb76cae2f in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb7b094fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#8  0xb75c0e5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xb36feb90 (LWP 3633)):
#0  0xb7fe0410 in __kernel_vsyscall ()
#1  0xb7b0fd05 in sem_wait@@GLIBC_2.1 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb71aace8 in Raul::Slave::_run (this=0x85caa68)
    at /home/kfoltman/src/drobilla/trunk/raul/raul/Semaphore.hpp:69
#3  0xb77ce546 in Raul::Thread::_static_run (me=0x85caa68)
    at /home/kfoltman/src/drobilla/trunk/raul/raul/Thread.hpp:86
#4  0xb7b094fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb75c0e5e in clone () from /lib/tls/i686/cmov/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 3 (Thread 0xb680bb90 (LWP 3630)):
#0  0xb71b09a4 in Ingen::InputPort::apply_poly (this=0xb2003e80, 
    maid=@0x80d5d20, poly=4) at InputPort.cpp:87
#1  0xb71bf2ba in Ingen::NodeBase::apply_poly (this=0xb2aeacc8, 
    maid=@0x80d5d20, poly=4) at NodeBase.cpp:126
#2  0xb71f760b in Ingen::LADSPANode::apply_poly (this=0xb2aeacc8, 
    maid=@0x80d5d20, poly=4) at LADSPANode.cpp:102
#3  0xb71cbbd9 in Ingen::PatchImpl::apply_internal_poly (this=0x8062b10, 
    maid=@0x80d5d20, poly=4) at PatchImpl.cpp:124
#4  0xb71f4ec9 in Ingen::SetPolyphonyEvent::execute (this=0x87c7c20, 
    context=@0x80ee8ac) at events/SetPolyphonyEvent.cpp:60
#5  0xb71d3f57 in Ingen::QueuedEventSource::process (this=0x80d5c88, 
    dest=@0x80d1318, context=@0x80ee8ac) at QueuedEventSource.cpp:105
#6  0xb71a82e7 in Ingen::Engine::process_events (this=0x80d59d0, 
    context=@0x80ee8ac) at Engine.cpp:310
#7  0xb71b20a9 in Ingen::JackAudioDriver::_process_cb (this=0x80ee7e0, 
    nframes=256) at JackAudioDriver.cpp:317
#8  0xb71b3864 in Ingen::JackAudioDriver::process_cb (nframes=256, 
    jack_driver=0x80ee7e0) at JackAudioDriver.hpp:153
#9  0xb7fb19e2 in jack_client_thread (arg=0x811fdc0) at client.c:1601
#10 0xb7b094fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#11 0xb75c0e5e in clone () from /lib/tls/i686/cmov/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 2 (Thread 0xb700cb90 (LWP 3629)):
#0  0xb7fe0410 in __kernel_vsyscall ()
#1  0xb7b0fd05 in sem_wait@@GLIBC_2.1 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb71d3e98 in Ingen::QueuedEventSource::_whipped (this=0x80d5c88)
    at /home/kfoltman/src/drobilla/trunk/raul/raul/Semaphore.hpp:69
#3  0xb71aacf4 in Raul::Slave::_run (this=0x80d5c90)
    at /home/kfoltman/src/drobilla/trunk/raul/raul/Slave.hpp:58
#4  0xb77ce546 in Raul::Thread::_static_run (me=0x80d5c90)
    at /home/kfoltman/src/drobilla/trunk/raul/raul/Thread.hpp:86
#5  0xb7b094fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0xb75c0e5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb72287a0 (LWP 3624)):
#0  0xb7fe0410 in __kernel_vsyscall ()
#1  0xb75b6c07 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0xb76a61c6 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb76a6577 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4  0xb577c264 in IA__gtk_main ()
    at /build/buildd/gtk+2.0-2.12.9/gtk/gtkmain.c:1163
#5  0xb5c55307 in Gtk::Main::run_impl () from /usr/lib/libgtkmm-2.4.so.1
#6  0xb5c550f2 in Gtk::Main::run () from /usr/lib/libgtkmm-2.4.so.1
---Type <return> to continue, or q <return> to quit---
#7  0xb5f50cb9 in Ingen::GUI::App::run (argc=2, argv=0xbff4e504, 
    world=0x80596d8) at App.cpp:138
#8  0xb5f4dd7b in run (argc=2, argv=0xbff4e504, world=0x80596d8) at gui.cpp:29
#9  0x0804b5dc in main (argc=2, argv=0xbff4e504) at main.cpp:206
0xb71b09a4	87				_buffers->at(i)->join(c->buffer(i));
(gdb) 

comment:3 Changed 13 years ago by kfoltman

A reliable way to reproduce:

  • run ingen
  • increase polyphony to (say) 5
  • import a patch
  • decrease polyphony to 4

Changed 13 years ago by kfoltman

Attachment: octsqr4voice5a.ingen.ttl added

This file seems to crash the r1627 of ingen, due to control-audio connection stuff

comment:4 Changed 13 years ago by David Robillard

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.