Opened 13 years ago

Closed 13 years ago

#236 closed Bug Report (fixed)

control blinkenports tend to get "stuck" displaying out-of-date values

Reported by: kfoltman Owned by:
Priority: major Component: Ingen
Keywords: Cc:

Description

In the attached Ingen patch, the displayed (via blinkenports) value of the Audio-to-control OR output port seems to get "stuck" on old value. The connected ports contain the "right" value (which can be inspected via Controls... dialog), however the value displayed on the GUI is not refreshed before the Controls... dialog is manually invoked.

The Timer plugin doesn't seem to cause any intentional (or easily spotted accidental) overwrites of its inputs, however, the Progress output changes very often (on each period when timer is running).

The problem is visible on Out port in Audio-to-control OR module, or the connected ports (Timer's Trigger or standalone control_output_1). Just play a couple of notes a second apart or so and observe those 3 ports. Sometimes one of them gets stuck at 100% while the connected ones remain at 0%. Or all ports get stuck at 100% (until Controls... dialog is invoked via right-click menu).

They're all connected so their values should (at least in theory) be the same.

Attachments (1)

blinken-weirdness.ingen.ttl (5.2 KB) - added by kfoltman 13 years ago.
unit test of some sort :)

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by kfoltman

Attachment: blinken-weirdness.ingen.ttl added

unit test of some sort :)

comment:1 Changed 13 years ago by David Robillard

Resolution: fixed
Status: newclosed

Seems fixed now, for -eg at least. Things like this are expected with OSC (OSC officially not supported right now, so fixed)

Note: See TracTickets for help on using tickets.