Opened 14 years ago

Closed 14 years ago

#25 closed Bug Report (fixed)

Crash on MIDI connect

Reported by: anonymous (jakobby) Owned by:
Priority: critical Component: Ingen
Keywords: Cc:

Description

When I connect something to a ingen MIDI input it crashes
Backtrace:

Core was generated by `/home/jakob/coding/drobilla-lad/ingen/src/progs/server/.libs/lt-ingen'.
Program terminated with signal 11, Segmentation fault.
#0  0xb763797c in _start () from /lib/ld-linux.so.2
(gdb) bt
#0  0xb763797c in _start () from /lib/ld-linux.so.2
#1  0x08080412 in Ingen::AlsaMidiPort::prepare_block (this=0x80ce160, block_start=55334656, block_end=55334912)
    at /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/include/g++-v4/bits/ostream.tcc:72
#2  0x080806d9 in Ingen::AlsaMidiDriver::process_midi_in (alsa_driver=0x80c2638) at AlsaMidiDriver.cpp:348
#3  0x08050bde in Ingen::JackAudioDriver::_sample_rate_cb (this=0xfffffffe, nframes=256) at JackAudioDriver.cpp:349
#4  0x080523e4 in Raul::Thread::start (this=0x100) at /home/jakob/coding/drobilla-lad/raul/raul/Thread.h:64

Change History (2)

comment:1 Changed 14 years ago by anonymous (jakobby)

Priority: majorcritical

Me again...
I traced the error to the memcpy in lv2midi_put_event from lv2-midifunctions.h
hope this helps...
btw: configured with no extra options given!

comment:2 Changed 14 years ago by David Robillard

Resolution: fixed
Status: newclosed

"Fixed" in that the bug was removed along with the rest of the Alsa MIDI driver. :)

Note: See TracTickets for help on using tickets.