Opened 13 years ago

Closed 13 years ago

#250 closed Bug Report (fixed)

Problem with connections to child patch

Reported by: t_w_@… Owned by:
Priority: major Component: Ingen
Keywords: child port Cc: t_w_@…

Description

Unable to make connection /child/child/audio_input_1 -> /child/child/audio_output_1 (Port not found) Unable to make connection /child/impulse_fc/Output -> /child/plate/Input (Port not found) Unable to make connection /child/plate/Left_output -> /child/Scape/in (Port not found) Unable to make connection /child/Scape/out_l -> /child

  • Add child patch
  • Just create audio input and output and connect them
  • connect ports of child patch in the root patch
  • save, quit, load:

Ingen complains in message window:

/audio_output_1 (Port not found) Unable to make connection /child/Scape/out_r -> /child/audio_output_1 (Port not found) Unable to make connection /child/plate/Right_output -> /child/Scape/in (Port not found) Unable to make connection /child/Scape/out_l -> /child/child/audio_input_1 (Port not found) Unable to make connection /child/Scape/out_r -> /child/child/audio_input_1 (Port not found) Unable to make connection /child/child/audio_output_1 -> /child/audio_output_1 (Port not found)

--

But graphically, everything is in place and connected.

Change History (2)

comment:1 Changed 13 years ago by t_w_@…

Oh, on the term (running ingen -eg):

Parsing document file:///media/sdb8/audio/ingen_test/noise-walker_with_child.ingen.ttl (base file:///media/sdb8/audio/ingen_test/noise-walker_with_child.ingen.ttl) WARNING: Unknown type for property ingen:enabled

comment:2 Changed 13 years ago by David Robillard

Resolution: fixed
Status: newclosed

Fixed in r1750.

Note: See TracTickets for help on using tickets.