Opened 13 years ago

Closed 13 years ago

#258 closed Bug Report (fixed)

build error with patchage

Reported by: andy@… Owned by:
Priority: major Component: Patchage
Keywords: Cc:

Description

I've just tried compiling ingen and patchage (by compiling the whole drobilla-lad repo), and I get this build error:

[ 65/231] cxx: patchage/src/PatchageCanvas.cpp -> build/default/patchage/src/PatchageCanvas_1.o ../patchage/src/PatchageCanvas.cpp: In member function 'boost::shared_ptr<PatchagePort?> PatchageCanvas::find_port(const PortID&)': ../patchage/src/PatchageCanvas.cpp:84: error: 'const union PortID::<anonymous>' has no member named 'jack_id' Build failed

-> task failed (err #129):

[bld:///local/drobilla-lad/drobilla-lad/patchage/src/PatchageCanvas_1.o]

the configure script also fails to check for libjack-dev, which I had to install after looking at an earlier error message.

My system is a chrooted debian testing installation.

Can anyone help?

Change History (3)

comment:1 Changed 13 years ago by David Robillard

What build options are you building with specifically? It purposefully does not build against libjack if you try to build with jack dbus.

comment:2 Changed 13 years ago by andy@…

I built it with no options - i.e. ./waf configure then ./waf to build. This didn't tell me I was missing libjack-dev

I've worked out the cause of the problem I reported though - it was because I hadn't properly cleaned the source tree between two different attempts at building it. It builds OK from a clean download. My problem now is that the reason I built it on a chrooted installation of testing was baecause one of the libraries in debian stable is too old for it, so I was trying it that way and hoping I could get it to run inside the chroot but still connect to the jack server on my main system outside the chroot. This doesn't work even when I mount the relevant jack socket files into /dev/shm inside the chroot, which seems to be because of a difference in the libjack versions between the two.

If you know of any way round this, I'd appreciate it, though I understand that this is a bit of an unusual setup and not really your problem.

comment:3 Changed 13 years ago by David Robillard

Resolution: fixed
Status: newclosed

Fixed in r1829.

Note: See TracTickets for help on using tickets.