Opened 13 years ago

Closed 13 years ago

#306 closed Bug Report (duplicate)

Assertion on connecting 2 audio ports to control input of child

Reported by: t_w_@… Owned by:
Priority: major Component: Ingen
Keywords: Cc: t_w_@…

Description

I replaced a few nodes with a sub-patch that should do the same. Edited with the patch disabled. Ended up with a patch that leads to a segfault as soon as it is run. Still can be loaded by disabling processing first.

Attachments (1)

code_02.ingen.ttl (25.5 KB) - added by t_w_@… 13 years ago.
Killer patch

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by t_w_@…

Attachment: code_02.ingen.ttl added

Killer patch

comment:1 Changed 13 years ago by t_w_@…

I'm currently running into an issue with segfaults on deleting i/o nodes, so I have a hard time trying to simplify this killer patch.

I highly suspect that the issue is about attaching audio to control ports of a child.

comment:2 Changed 13 years ago by t_w_@…

Summary: Patch segfaults when runAssertion on connecting 2 audio ports to control input of child

Tracked this issue down:

  • Add 2 audio inputs
  • Add child
  • Add control input in child
  • Connect both audio nodes to control port of child:
ingen: ../ingen/src/engine/AudioBuffer.cpp:222: void Ingen::AudioBuffer::accumulate(const Ingen::AudioBuffer*, size_t, size_t): Assertion `end_sample < _size' failed.
Aborted

comment:3 Changed 13 years ago by t_w_@…

Resolution: duplicate
Status: newclosed

Fixed as of r1889. Same issues as #308, apparently.

Note: See TracTickets for help on using tickets.