Opened 12 years ago

Closed 11 years ago

#461 closed Bug Report (fixed)

Changing symbol and label changes the label of the audio input/output on the ingen gui

Reported by: fenixin@… Owned by: David Robillard
Priority: minor Component: Ingen
Keywords: ingen label symbol Cc:

Description

Is this a bug?:

  • Open ingen "ingen -ge"
  • Create an audio input
  • Rename the symbol to 'thing1' and you see thing1 on ingen gui
  • Rename the label to 'nothing1' an you see nothing1 on ingen gui
  • Rename the symbol to 'something1' and you see something1 on ingen gui
  • It's expected to change only with the label.

Change History (4)

comment:1 Changed 12 years ago by David Robillard

Resolution: invalid
Status: newclosed

Symbol is the restricted identifier and jack name, not label.

comment:2 Changed 12 years ago by fenixin@…

I think I complicated it... or maybe I don't understand it.

If label is what you should see on ingen then something is wrong. When I click rename on an audio input/output, change the value symbol and hit ok the name on ingen get the value of symbol. And if I change label is what I get on ingen. The last changed value is what I get on ingen.

:?

comment:3 Changed 11 years ago by fenixin@…

Resolution: invalid
Status: closedreopened

This bug is still there on revision 2396. Changing symbol changes the label on ingen canvas.

comment:4 Changed 11 years ago by David Robillard

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.