Opened 11 years ago

Closed 11 years ago

#505 closed Bug Report (duplicate)

Ingen build AudioBuffer failure

Reported by: antonio.tobon@… Owned by: anonymous
Priority: major Component: Build System
Keywords: AudioBuffer, Ingen Cc:

Description

Hi!

I've tried a lot to build Ingen, but i'm only getting to the building part, and having this little problem:


root@tobonremoto-laptop:/home/tobonremoto/drobilla-lad/drobilla-lad# ./waf build --force Waf: Entering directory `/home/tobonremoto/drobilla-lad/drobilla-lad/build' [ 46/203] cxx: ingen/src/engine/AudioBuffer.cpp -> build/default/ingen/src/engine/AudioBuffer_1.o ../ingen/src/engine/AudioBuffer.cpp:22:27: error: atom.lv2/atom.h: No existe el fichero ó directorio In file included from ../ingen/src/engine/AudioBuffer.hpp:25,

from ../ingen/src/engine/AudioBuffer.cpp:24:

../ingen/src/engine/ObjectBuffer.hpp:46:2: error: ISO C++ prohíbe la declaración de ‘LV2_Atom’ sin tipo ../ingen/src/engine/ObjectBuffer.hpp:46:10: error: expected ‘;’ before ‘*’ token ../ingen/src/engine/ObjectBuffer.hpp:47:2: error: expected `;' before ‘const’ ../ingen/src/engine/ObjectBuffer.hpp:47:8: error: ISO C++ prohíbe la declaración de ‘LV2_Atom’ sin tipo ../ingen/src/engine/ObjectBuffer.hpp:47:16: error: expected ‘;’ before ‘*’ token ../ingen/src/engine/ObjectBuffer.hpp:49:1: error: expected `;' before ‘private’ ../ingen/src/engine/ObjectBuffer.hpp:50:2: error: ISO C++ prohíbe la declaración de ‘LV2_Atom’ sin tipo ../ingen/src/engine/ObjectBuffer.hpp:50:10: error: expected ‘;’ before ‘*’ token In file included from ../ingen/src/engine/AudioBuffer.cpp:24: ../ingen/src/engine/AudioBuffer.hpp:71:2: error: ISO C++ prohíbe la declaración de ‘LV2_Vector_Body’ sin tipo ../ingen/src/engine/AudioBuffer.hpp:71:17: error: expected ‘;’ before ‘*’ token ../ingen/src/engine/AudioBuffer.hpp:73:2: error: expected `;' before ‘State’ ../ingen/src/engine/AudioBuffer.hpp: In member function ‘Sample* Ingen::AudioBuffer::data() const’: ../ingen/src/engine/AudioBuffer.hpp:50:21: error: ‘atom’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.hpp:51:39: error: ‘LV2_Vector_Body’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.hpp: In member function ‘SampleCount? Ingen::AudioBuffer::nframes() const’: ../ingen/src/engine/AudioBuffer.hpp:57:23: error: ‘LV2_Atom’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.hpp:57:42: error: ‘LV2_Vector_Body’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp: In constructor ‘Ingen::AudioBuffer::AudioBuffer?(Ingen::BufferFactory?&, Ingen::Shared::PortType?, size_t)’: ../ingen/src/engine/AudioBuffer.cpp:52:8: error: ‘atom’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp:57:8: error: ‘atom’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp:58:3: error: ‘LV2_Vector_Body’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp:58:20: error: ‘body’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp:58:44: error: expected primary-expression before ‘)’ token ../ingen/src/engine/AudioBuffer.cpp:58:45: error: expected `;' before ‘atom’ ../ingen/src/engine/AudioBuffer.cpp: In member function ‘virtual void Ingen::AudioBuffer::resize(size_t)’: ../ingen/src/engine/AudioBuffer.cpp:78:38: error: ‘LV2_Vector_Body’ no se declaró en este ámbito ../ingen/src/engine/AudioBuffer.cpp:79:9: error: missing template arguments before ‘(’ token Waf: Leaving directory `/home/tobonremoto/drobilla-lad/drobilla-lad/build' Build failed

-> task failed (err #1):

{task: cxx AudioBuffer?.cpp -> AudioBuffer_1.o}


¿can anybody help?

Change History (5)

comment:1 Changed 11 years ago by anonymous

Owner: changed from David Robillard to anonymous

comment:2 Changed 11 years ago by David Robillard

Resolution: invalid
Status: newclosed

Looks like you have just the ingen subdirectory checked out. You need to check out my entire "lad" repository http://svn.drobilla.net/lad/trunk/ (but you can still build ingen by itself if you like)

comment:3 Changed 11 years ago by anonymous

Resolution: invalid
Status: closedreopened

Same as me. I got ALL sources with

svn co http://svn.drobilla.net/lad/trunk drobilla-lad

comment:4 Changed 11 years ago by David Robillard

You checked out a brand new, fresh repository, very recently, and got this error?

comment:5 Changed 11 years ago by David Robillard

Resolution: duplicate
Status: reopenedclosed

Should be a duplicate of ticket #600 now (LV2 headers are checked at configuration time, and the includes are different, so this bug cannot possibly still exist in the exact same form).

Note: See TracTickets for help on using tickets.