Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#535 closed Bug Report (fixed)

svn trunk top-level build broken

Reported by: nettings@… Owned by: David Robillard
Priority: blocker Component: Build System
Keywords: waf build Cc:

Description

hi! current drobilla-svn doesn't seem to build.

python complains about missing modules (RDF, configure), which should be there... mine is a spanking new opensuse 11.3 installation, so i figured it might be a problem on my end, but nedko has confirmed the issue on irc: <nedko> # ./waf configure

<nedko> /home/nedko/git/drobilla-lad/trunk/wscript: error: Traceback (most recent call last):

<nedko> File "/home/nedko/git/drobilla-lad/trunk/.waf-1.5.18-487adbf62788e8f9f87c933ad1f53883/wafadmin/Utils.py", line 199, in load_module

<nedko> exec(compile(code,file_path,'exec'),module.dict)

<nedko> File "/home/nedko/git/drobilla-lad/trunk/wscript", line 10, in <module>

<nedko> import lv2include

<nedko> ImportError?: No module named lv2include

Change History (5)

comment:1 Changed 11 years ago by David Robillard

I think maybe svn doesn't update properly when a directory is changed to an external. Did you get this warning?

Fetching external item into 'trunk/lv2' svn: warning: 'trunk/lv2' is already a working copy for a different URL

Try this:

rm -rf lv2 svn up ./waf configure

comment:2 Changed 11 years ago by Ray Rashif <schivmeister@…>

Hi guys

We need redland-bindings for python (./configure --with-python). I didn't get this error, but I know where this issue comes from, and that's the RDF import error. For that, many mistake rdflib to be providing the modules. I guess this should now be a third-party dependency if you don't want to include it in the repo, since we didn't have this issue before.

http://librdf.org/bindings/INSTALL.html redland-bindings-1.0.11.1.tar.gz

comment:3 Changed 11 years ago by David Robillard

Yes, the missing RDF module is redland. I suppose I should add a check for that.

The added build dependency is unfortunate I suppose, maybe I should generate it and keep the symlink tree in svn... bit messy though... I'll think about it

comment:4 Changed 11 years ago by David Robillard

Resolution: fixed
Status: newclosed

Fixed: The script now supports both Redland (module RDF) and RDFLib (module rdflib). It now prints a proper error message if neither is found.

comment:5 Changed 11 years ago by nettings@…

i just checked out a fresh tree (to make sure i wouldn't run into svn-external-related issues), and the top-level build process works just fine now. thanks for the quick fix!

Note: See TracTickets for help on using tickets.