Opened 11 years ago

Closed 11 years ago

#554 closed Bug Report (fixed)

[slv2] event.h: No such file or directory

Reported by: Ray Rashif <schivmeister@…> Owned by: David Robillard
Priority: major Component: Build System
Keywords: Cc:

Description

This is the build log:

Global Configuration Checking for program gcc or cc : /usr/bin/gcc Checking for program cpp : /usr/bin/cpp Checking for program ar : /usr/bin/ar Checking for program ranlib : /usr/bin/ranlib Checking for gcc : ok Checking for program g++ or c++ : /usr/bin/g++ Checking for program ar : /usr/bin/ar Checking for program ranlib : /usr/bin/ranlib Checking for g++ : ok Install prefix : /usr Debuggable build : False Strict compiler flags : False Build documentation : False

SLV2 Configuration Checking for lv2core : yes Checking for redland >= 1.0.6 : yes Checking for jack >= 0.107.0 : yes Jack clients : True Unit tests : False Dynamic Manifest Support : False Default LV2_PATH : ~/.lv2:/usr/local/lib/lv2:/usr/lib/lv2

'configure' finished successfully (0.239s) Waf: Entering directory `/home/abs/aur/slv2-svn/src/lad/slv2/build' [ 1/22] cc: src/collections.c -> build/default/src/collections_2.o [ 2/22] cc: src/plugin.c -> build/default/src/plugin_2.o [ 3/22] cc: src/pluginclass.c -> build/default/src/pluginclass_2.o [ 4/22] cc: src/plugininstance.c -> build/default/src/plugininstance_2.o [ 5/22] cc: src/plugins.c -> build/default/src/plugins_2.o [ 6/22] cc: src/pluginui.c -> build/default/src/pluginui_2.o [ 7/22] cc: src/pluginuiinstance.c -> build/default/src/pluginuiinstance_2.o [ 8/22] cc: src/port.c -> build/default/src/port_2.o [ 9/22] cc: src/query.c -> build/default/src/query_2.o [10/22] cc: src/scalepoint.c -> build/default/src/scalepoint_2.o [11/22] cc: src/util.c -> build/default/src/util_2.o [12/22] cc: src/value.c -> build/default/src/value_2.o [13/22] cc: src/world.c -> build/default/src/world_2.o [14/22] cc: utils/lv2_inspect.c -> build/default/utils/lv2_inspect_3.o [15/22] cc: utils/lv2_list.c -> build/default/utils/lv2_list_4.o [16/22] cc: hosts/lv2_jack_host.c -> build/default/hosts/lv2_jack_host_5.o In file included from ../hosts/lv2_jack_host.c:31:0: ../hosts/event.lv2/event-helpers.h:28:52: fatal error: lv2/http/lv2plug.in/ns/ext/event/event.h: No such file or directory compilation terminated. Waf: Leaving directory `/home/abs/aur/slv2-svn/src/lad/slv2/build' Build failed: -> task failed (err #1):

{task: cc lv2_jack_host.c -> lv2_jack_host_5.o}

Aborting...

And this is the problem:

There is no such directory structure to be found in the repository. The only 'event.h' which exists in lv2/ext/event.lv2/ will fail if included in event-helpers.h:

In file included from ../hosts/event.lv2/event-helpers.h:28:0, from ../hosts/lv2_jack_host.c:31: /usr/include/event.h:727:2: error: expected specifier-qualifier-list before ‘u_char’ /usr/include/event.h:1146:8: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before ‘*’ token

System has the latest of every software component.

Change History (4)

comment:1 Changed 11 years ago by Ray Rashif <schivmeister@…>

Oops, forgot to format the stuff. Plus, it'd look weird and stretched, so here's a paste instead: http://pastebin.com/xyvMqUpJ

comment:2 in reply to:  1 Changed 11 years ago by Ray Rashif <schivmeister@…>

Ahh crap. Title should read "event.h: No such file or directory"

comment:3 Changed 11 years ago by Ray Rashif <schivmeister@…>

Summary: [slv2] lv2.h: No such file or directory[slv2] event.h: No such file or directory

comment:4 Changed 11 years ago by David Robillard

Resolution: fixed
Status: newclosed

Either fixed, or changed to be a duplicate of ticket #600.

Note: See TracTickets for help on using tickets.