Opened 11 years ago

Closed 10 years ago

#627 closed Bug Report (fixed)

Patch to make lv2config working with Python 3

Reported by: alessio@… Owned by: David Robillard
Priority: major Component: LV2
Keywords: python3 Cc:

Description

Hi!

The attached patch makes the lv2config tool compatible with Python 3.

Attachments (1)

lv2config_python3.patch (2.6 KB) - added by alessio@… 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by alessio@…

Attachment: lv2config_python3.patch added

comment:1 Changed 11 years ago by anonymous

...and please note that the print_function is available in the future module since Python 2.6.

So, shortly: currently lv2config works fine with Python << 3, with my patch the support would change to >> Python 2.5

comment:2 Changed 10 years ago by David Robillard

Resolution: fixed
Status: newclosed

Applied, thanks.

Note: See TracTickets for help on using tickets.