Opened 15 years ago

Closed 13 years ago

#7 closed Bug Report (fixed)

Not Letting Go After Grabbing Cursor

Reported by: Esben Stien Owned by:
Priority: major Component: FlowCanvas
Keywords: canvas, grab cursor, stuck Cc:

Description

This bug is known to be deep and will probably disappear with the cairo port. Sometimes the mouse is stuck in a state not able to click anything at all on the desktop. It's also in most cases not possible to use the keyboard, at all. The only option is to remotely log in and kill it.

Change History (7)

comment:1 Changed 15 years ago by David Robillard

I havn't seen this one in ages. If you can get instructions to reproduce it I can probably fix it.

Much simpler known workaround is switching desktops (or probably to the console and back).

comment:2 Changed 14 years ago by David Robillard

Resolution: fixed
Status: newclosed

Assuming fixed.

comment:3 Changed 13 years ago by t_w_@…

Priority: criticalmajor
Resolution: fixed
Status: closedreopened

Happens with Ingen, lad revision 1872.

Testcase: add audio input and output nodes, alternatingly click the ports of them. Increase speed of doing so. Pointer will get stuck in cross mode and not allow to click anywhere.

comment:4 Changed 13 years ago by David Robillard

Can't reproduce...

comment:5 Changed 13 years ago by t_w_@…

Just tested with r1904, still happens. I do have to click like a madman for this to happen with the simple test case, but the problem comes up in normal use sometimes.

Cursor can be brought back to normal with Alt-F (or other menu mnemonic).

comment:6 Changed 13 years ago by t_w_@…

As of r1909, the cursor can be brought back to normal with a single click anywhere.

comment:7 Changed 13 years ago by David Robillard

Resolution: fixed
Status: reopenedclosed

Well... good enough for me ;)

Debugging has shown the grab/ungrab sequence being perfect in cases where this is triggered (as of a few revisions ago anyway). The grab that steals the cursor /is/ being ungrabbed. Tempted to say this is a Gtk and/or Gnomecanvas bug.

Anyway, if a click makes it go away it's harmless enough now, closing bug.

Note: See TracTickets for help on using tickets.