Opened 7 years ago

Closed 7 years ago

#995 closed Bug Report (fixed)

libingen_socket_server.so missing

Reported by: Erik Owned by: David Robillard
Priority: major Component: Ingen
Keywords: Cc:

Description

When running "ingen -eg" I get the error: Unable to find socket_server (/usr/local/lib/libingen_socket_server.so: cannot open shared object file: No such file or directory)

I did get an error on ./waf configure "AttributeError?: 'Values' object has no attribute 'python'"

It did however let me continue to install and for example I can see in the install output:

  • install /usr/local/lib/libingen_server.so (from build/ingen/src/server/libingen_server.so)

...but I don't see any reference to that socket file.

Change History (4)

comment:1 Changed 7 years ago by David Robillard

Python thing should be fixed in r5503. Not sure if this would be the cause of the socket library not being compiled, try again now (you must reconfigure).

If it's not built there should be something in the configure output about that, if it still doesn't work paste that or build/config.log

comment:2 Changed 7 years ago by Erik

Yep the python error is gone (thanks) but I am still missing that socket shared obj. The only error I saw was something about gtk quartz (I thought quartz was a mac thing?).

btw - Patchage and Machina run (at least on a surface level). I built the whole repo.

Here's my configure log: <cropped>

Last edited 7 years ago by David Robillard (previous) (diff)

comment:3 Changed 7 years ago by David Robillard

The above was cropped because of the comment length limit. Please attach the file instead.

comment:4 Changed 7 years ago by David Robillard

Resolution: fixed
Status: newclosed

Nevermind, fixed in r5516.

Note: See TracTickets for help on using tickets.